关于ApacheLog4j 远程代码执行漏洞的预警通知

发布者:系统管理员发布时间:2021-12-10浏览次数:11

Apache Log4j  Apache 的一个开源项目,Apache Log4j2是一个基于Java的日志记录工具。该工具重写了Log4j框架,并且引入了大量丰富的特性。我们可以控制日志信息输送的目的地为控制台、文件、GUI组件等,通过定义每一条日志信息的级别,能够更加细致地控制日志的生成过程。该日志框架被大量用于业务系统开发,用来记录日志信息。

Log4j-2中存在JNDI注入漏洞,当程序将用户输入的数据被日志记录时,即可触发此漏洞,成功利用此漏洞可以在目标服务器上执行任意代码。Apache Struts2Apache SolrApache DruidApache Flink等均受影响。


影响版本:Apache Log4j 2.x <= 2.15.0-rc2


鉴于该风险影响范围广,利用门槛极低,潜在危害程度高,请各单位(部门)高度重视,迅速组织排查单位重要信息系统是否存在使用Log4j框架的情况。如存在相关情况,请及时开展整改加固及安全监测工作,并立即采取以下应对措施。

一是排查已知受影响的应用及组件,涉及srping-boot-strater-log4j2Apache SolrApache FlinkApache Druid等。

二是升级Apache Log4j2所有相关应用到最新的 log4j-2.15.0-rc2 版本,升级地址:https://github.com/apache/logging-log4j2/releases/tag/log4j-2.15.0-rc2


三是加强网络安全监测,发现安全事件及时报告网络与教育技术中心。